MySQL 3.51

Автор tikhonovaleksei, ноября 21, 2015, 12:14:06 pm

« предыдущая - следующая »

tikhonovaleksei

Добрый день!

Использую Qlik Sense (серверную платную)

Как подключиться к БД MySQL 3.51?

При попытке соединения вылазит сообщение о том что MySQL ниже 5 версии не поддерживается.

Что нужно сделать, провайдер какой-нибудь поставить?

Заранее спасибо!

admin

Привет,
ну как бы да, староватенько. Надо поискать соответствующий драйвер, может удастся подцепиться.

http://dev.mysql.com/downloads/connector/odbc/3.51.html

tikhonovaleksei

спасибо,

на сервер с qlik поставил провайдер, и прописал источник данных и qlik его видет.

но у меня тут фокусы поинтереснее, на самом деле у меня не бд mysql а sphinx который работает по протоколу mysql. например если подключиться катм нибудь клиентом для работы с БД то таблиц никаких не будет видно вообще, но если выполнить определенный запрос SQL то получим выборку с результами полнотекстового поиска.и провайдер ODBC нормально реагирует на такое.

проблема в другом чтобы qlik стал работаеть ему нужно указать таблицы. а так как таблиц не видно не понятно как делать.

вопрос - можно ли клику сенс в качестве таблицы скормить результаты SQL запроса, при чем чтобы текст запроса был родным для mysql. и дальше в direct discovery генерить запросы и получит данные

Рейтинг@Mail.ru Яндекс.Метрика